[VMC HCX] HCX Plugin not responding to any action and failed to deploy
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[VMC HCX] HCX Plugin not responding to any action and failed to deploy

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Article ID: 329684

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

This addresses the resolution to HCX showing 'Active' in the VMC Console Add-ons tab when it had previously been uninstalled. 

Symptoms:
HCX was undeployed from the VMC SDDC, however it is still showing as active on the VMC Console.

Cause

When attempting to access the HCX Plug-In through vCenter or selecting 'Open HCX' through the VMC Console Add-ons tab, it will fail to load. This is expected as there is no HCX Manager deployed in the vCenter. There is likely some internal cleanup that is required to ensure all HCX components are successfully removed, to completely uninstall HCX from VMC. 

Resolution

Confirm if all steps have been completed to remove HCX from VMC - Uninstall HCX deployment from Connector & Cloud (74869) (vmware.com). If HCX is still showing 'Active' under the VMC Console after deactivating HCX, please create a support request with VMC Global Support (Creating and managing Broadcom support cases) with the following information:

  • SDDC ID
  • Time/Date when HCX was uninstalled
  • Screenshot of the VMC Console Add-ons tab showing HCX is still active
  • Screenshot of the Mgmt-ResourcePool from vCenter showing that no HCX Appliances are present
  • Confirmation that HCX can be entirely removed from the SDDC



Workaround:
If after the cleanup is completed, and the HCX plug-in is still present within the vCenter, the following process can be performed to remove the plug-in - Uninstall HCX deployment from Connector & Cloud (74869) (vmware.com).

Additional Information

Impact/Risks:
This is preventing HCX from being completely uninstalled from the SDDC. This will prevent any future redeployments of HCX in the SDDC until it is completely cleaned up.