Error on HCX plugin or HCX manager "Your session is no longer valid, you need to login again to view and manage HCX operations"
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Article ID: 329653
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Updated On:
Products
VMware Cloud on AWS
Issue/Introduction
When you login to HCX plugin or HCX manager url you see a banner error with text "Your session is no longer valid, you need to login again to view and manage HCX operations".
Cause
This could happen because of multiple reasons -
1) vCenter session expired 2) Time sync issue between vCenter and HCX Manager 3) Incorrect or broken hcx role mapping
Resolution
To resolve this issue we can try following steps
1) Log off and log back in 2) Try logging in to an incognito/inprivate mode 3) Log in to HCX manager config page and verify the time and date it should be in syc with vCenter. 4) do an ssh to hcx manager using admin credentials, go to /common/logs/admin and check web.log
if you find entries similar to
ERROR c.v.v.h.a.VSphereSamlTokenAuthenticator- Could not assign NSP role based on logged in VCenter user group memberships
the issue is with HCX role mapping either the user you are logged in with is not a part of group you defined in role mapping section of hcx manager or role mapping is broken.
to double check add vsphere.local/administrators to role mapping and try logging in with [email protected] to vcenter or hcx manager it should not show session expired error.