[VMC on AWS] How to change the connected VPC subnet after an SDDC deployment
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[VMC on AWS] How to change the connected VPC subnet after an SDDC deployment

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Article ID: 329587

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

This article provides information on how to change the connected VPC subnet.

Cause

The connected VPC subnet can't be changed from the VMC console after it has been connected once. Some work needs to be done by VMware.

Resolution

1. If you would like to change the connected VPC subnet with the same AWS account.
Please contact VMware support with the following information.
  • AWS Account number
  • VPC ID
  • Subnet ID
Note: A new subnet must be the same availability zone as the current one.

2. If you would like to change the connected VPC subnet with another AWS account.
Deploy an AWS cloudformation stack with a new AWS account.
  • Login to https://vmc.vmware.com
  • Select "VMware Cloud on AWS"
  • Click "CREATE SDDC" button
  • Enter a temporary name in "SDDC Name" field and click "NEXT" button
  • Select "Connect to AWS now" and choose "Connect to a new AWS account"
  • Click "OPEN AWS CONSOLE WITH CLOUDFORMATION TEMPLATE" button
  • Login to AWS console after the page transition
  • Select "I acknowledge that AWS CloudFormation might create IAM resources" and click "Create" button
  • Wait for the stack creation to be completed
Note: You don't have to create a new SDDC. You can quit after the stack creation on the AWS side.

Please contact VMware support with the following information after you performed the No.2-1.
  • AWS Account number
  • VPC ID
  • Subnet ID
Note: A new subnet must be the same availability zone as the current one.


Additional Information

Engage VMware Support

Impact/Risks:
This is not a process that can be run instantly. This requires a maintenance window at least 1 week in out from the date of SR submission.