[VMC on AWS] Unable to access Identity Sources menu from vCenter
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Article ID: 329425
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Updated On:
Products
VMware Cloud on AWS
Issue/Introduction
Provides details about how to troubleshoot and work towards issue resolution.
Symptoms:
Upon navigating to SingleSign On > Configuration menu in vCenter, the Identity Sources tab will not be visible.
Instead of seeing the Identity Sources tab, Identity Provider tab may be seen (which won't be accessible due to lack of privileges even with [email protected])
Cause
The issue was caused because a VMC-specific property was not set in the vSphere UI client of the SDDC.
Resolution
Confirm that there was an attempt to access the Identity Sources menu after logging in using [email protected] user which will have the CloudAdmin role. This is done to ensure that this is not a privilege issue.
Rule out any/all browser-related issue by attempting to access the Identity Sources menu from different browsers and using incognito mode.
Once the above two above two possible causes are ruled out, kindly reach out to VMware support by opening an SR with the following details:-
SDDC ID
Screenshot of SingleSign On > Configuration menu in vCenter
HAR file collected from the browser when the issue is reproduced.
Impact/Risks: During the course of troubleshooting, VMware support may need to restart vsphere-ui service of vCenter which will lead to vCenter UI not being accessible for a brief amount of time. This will not affect workload VMs.