[VMC] Provisioning an SDDC fails with an internal error
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[VMC] Provisioning an SDDC fails with an internal error

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Article ID: 329418

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

Attempting to provision an SDDC fails with the below error:

"An internal error has occurred  We could not load your AWS VPCs and subnets, please try again"

Environment

VMC on AWS

Cause

  • Settings need to be manually updated if using settings other than the defaults. 
  • The settings need to be manually updated. 

Resolution

To resolve this issue, manually update the settings following the below steps:

  1. Login to the AWS Management Console to Create a New Default Virtual Private Connection (VPC) in Services, Network and Content Delivery and then VPC.
  2. Create the VPC by using VPC option.
  3. Under the Create VPC section provide the IPv4 Cider Block and click Yes create. Note: AWS typically provides a CIDR block of 172.31.0.0/16.
  4. Click on the Subnets Tab.
  5. Create Subnets for each availability zone. 
  6. Click Internet Gateways Tab.
  7. Create the Internet Gateway by providing Name tag.
  8. Associate a Virtual Private Connection (VPC) to Internet Gateway by right clicking and selecting the Attach to VPC option.
  9. Under the Attach VPC section select a VPC from the drop list and click Attach to complete
  10. To validate Internet Gateway connectivity to the VPC, click on the Route Tables and select the newly created VPC.
  11. Under the the Routes Tab, click the Edit Button and add the route by clicking in the Destination field and adding the 0.0.0.0/0. Define the Target which should be auto populated.

Once this process has been followed, attempt to provision the SDDC again. 

Additional Information