[VMC on AWS] Unable to upload data to Content Library
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[VMC on AWS] Unable to upload data to Content Library
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Article ID: 329407
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Updated On: 05-25-2020
Products
VMware Cloud on AWS
Issue/Introduction
Symptoms:
Unable to export data to existing Content Library
Logs similar to below are seen
warning vpxa[2108114] [Originator@6876 sub=Libs] [NFC ERROR]NfcProcessFileDataMsg: NfcContinueFileReceive failed: There is no disk space available (NFC_NO_DISKSPACE)
warning vpxa[2108114] [Originator@6876 sub=Libs] [NFC ERROR]NfcProcessStreamMsg: Could not process NFC_FILE_DATA message: NFC_NO_DISKSPACE (There is no disk space available)
warning vpxa[2108114] [Originator@6876 sub=Libs] [NFC ERROR]Sending Nfc error 14: There is no disk space available -- Failed to write to the target file: There is no space left on the device
error vpxa[2108114] [Originator@6876 sub=vpxNfcServer] Read error from the nfcLib: NFC_NO_DISKSPACE (done = yep)
Cause
Content Library is currently limited by the maximum VSAN component size of 255 GB as it writes its data in a home directory on the VSAN datastore.
VSAN home directories are unable to expand past 255 GB
Resolution
Workaround: Create a new Content Library for additional files that would exceed 255 GB.