Sample ACFRPTOM report showing the getUMAP or getGMAP errors:
getGMAP USER001 SYSPROG 0 20 8 8 4
11/02/15 15.306 12.59.41 USER001 I21A I21A
Failed - GID not defined or group not defined as OpenMVS group
GID value: 7
Map name: Search by GID, return groupname
getUMAP T2184PK SYSPROG 0 20 8 8 4
11/04/15 15.308 13.56.57 T2184PK I21A I21A
Failed - UID not defined or user not defined as OpenMVS user
UID value: 23456
Map name: Search by UID, return userid
ACF2 z/OS, USS Callable Services, ACF2 ACFRPTOM Report errors
Cause:
The getUMAP or getGMAP errors seen in the ACFRPTOM report are due to a file or directory that have a UID or GID assigned to them but no User or Group Profile record associated with the GID or UID. When a USS service is invoked to display the UID or GID, a USS getUMAP or getGMAP callable service is invoked request the associated user or group. If there is no user or group for the UID or GID the USS getUMAP or getGMAP callable service will fail with the 8/8:4 return codes.
Typically these errors occur when a user(logonid) with a unique Group and User Profile creates files or directories in USS and subsequently the user's logonid, User and Group Profile are deleted. Since the USS permission bits retain the UID
and GID of the user that created the file or directory, the associated user or groupprofile record for that UID or GID no longer exist, and any getUMAP or getGMAP calls will fail with the 8/8:4 return codes.
Resolution:
To verify if there is a User or Group Profile for a specific UID or GID
the following ACF2, TSO ACF command can be issued.
ACF
show omvs user(23456)
ACF
show omvs group(7)
To address the problem there are two options.
1) Create a User or Group Profile record for the UID or UID identified in the
ACFRPTOM report.
2) Change the USS permissions of the files or directories associated with the
UID or GID indentified in the ACFRPTOM report.
Additional Information:
For details on the ACF SHOW OMVS command see the CA ACF2 for z/OS Administration
Guide, Chapter 3: Maintaining Logonid Records, section 'USER Profile Records' sub-section 'SHOW OMVS'.
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