SD-WAN High Availability edge upgrade fails and does not retry.
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SD-WAN High Availability edge upgrade fails and does not retry.

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Article ID: 329099

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
During testing of software releases, it was discovered when upgrading a High Availability pair of edges the upgrade may not complete and will not retry automatically.

Environment

VMware SD-WAN

Cause

The issue is being tracked under ID #105160.

The issue causes an exception in the Edge upgrade process which prevents the edge from upgrading as it assumes the upgrade was completed.

Resolution

This issue was resolved in these GA releases, SD-WAN Edge version 5.0.1.4 build R5014-20230713-GA (5.0.1 Release Notes), and in 5.2.0.0 (5.2.0 Release Notes )


For information on how to upgrade please check the following article: VMware SD-WAN Software Upgrade FAQs

Workaround:
If this issue is encountered in the field, follow these steps as a workaround:
  1. Change the Edge version to a different version (downgrade or upgrade)
  2. After the Edge software update, retry the desired upgrade for the Edge.


Additional Information

Impact/Risks:
It is not suspected that customers would encounter this issue in the field, as we discovered this during internal software testing and fixed it within the GA release for the affected versions.