The SoS utility fails to generate NSX-T support-bundles
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The SoS utility fails to generate NSX-T support-bundles

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Article ID: 329040

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Updated On:

Products

VMware NSX

Issue/Introduction

Symptoms:
In the report.json, You see the error:

SoS report.json message:
"Download failed with Resp_code: 409 and Message: Another support bundle is ready for download: /api/v1/node/tasks/########-####-####-####-########c5d8_########-####-####-####-########10d8/response."

Sample report.json output
=========================
root@sddc-manager [ /opt/vmware/sddc-support ]# ./sos --nsx-logs 
Welcome to Supportability and Serviceability(SoS) utility!
Performing SoS operation for sddcId-1001 domain components
Logs : /var/log/vmware/vcf/sddc-support/sos-20##-##-##-##-##-21-61514
Log file : /var/log/vmware/vcf/sddc-support/sos-20##-##-##-##-##-21-61514/sos.log
Operation failed for : [NSX_MANAGER]                                                                                
For detailed report please refer : /var/log/vmware/vcf/sddc-support/sos-20##-##-##-##-##-21-61514/report.json
root@sddc-manager [ /opt/vmware/sddc-support ]# cat /var/log/vmware/vcf/sddc-support/sos-20##-##-##-##-##-21-61514
cat: /var/log/vmware/vcf/sddc-support/sos-20##-##-##-##-##-21-61514: Is a directory
root@sddc-manager [ /opt/vmware/sddc-support ]# cat /var/log/vmware/vcf/sddc-support/sos-20##-##-##-##-##-21-61514/report.json 
{
    "NSX_MANAGER": {
        "overall_status": "COMPLETED_WITH_FAILURE",
        "message": "",
        "subtasks": [
            {
                "name": "vip-nsx-mgmt.vrack.vsphere.local",
                "status": "FAILED",
                "message": "NSX log collection completed with failure"
            },
            {
                "name": "nsxt_manager : vip-nsx-mgmt.vrack.vsphere.local",
                "status": "FAILED",
                "message": "Download failed with Resp_code: 409 and Message: Another support bundle request is running: /api/v1/node/tasks/########-####-####-####-########c5d8_########-####-####-####-########602e/response. Please wait until the current request finishes before retrying."
            }
        ]
    },
    "operation-status": "COMPLETED_WITH_FAILURE"
}


Environment

VMware NSX-T

Cause

This issue occurs when a NSX-T support bundle is created from NSX UI then a support bundle is triggered from SoS (/opt/vmware/sddc-support/sos).

SoS does not override existing support-bundle generated from the NSX UI causing the SoS log to fail.

Resolution

To resolve this issue, remove the NSX UI created log bundle:
  1. Login to NSX UI with admin credentials.
  2. Navigate to System > Support Bundle.
  3. Delete the existing bundle by clicking DELETE next to Support  Bundle.
  4. Run the SoS operation again.