Cannot Attach Documents To The Repository In Service Desk After Enabling SSL

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Article ID: 32901

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Desk Manager

Issue/Introduction

Cannot attach documents to tickets after enabling SSL In Service Desk Manager (SDM). It keeps waiting forever.

 

 

Cause

The problem is that the repository and SDM must use the same protocol so we need to configure the repository to use SSL too.

 

Environment

Release: SDMU0M99000-14.1-Service Desk Manager-Full License
Component:

Resolution

1) Go to Administration Tab > Attachments Library > Repositories
2) Select Repository you need to use and configure with SSL > Right-Click and View
3) Take note of the Server being used
4) Go to System > Servers > Click on the Server > Edit
5) Configure the "Attachment Servlet Path" to use SSL as SDM. For example: https://hostname_of_server:8443/CAisd/UploadServlet
6) Save
7) Attaching the file again using SDM in SSL should work now