Upgrade to vRealize Automation 7.3 fails while running post-install scripts
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Upgrade to vRealize Automation 7.3 fails while running post-install scripts

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Article ID: 328664

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • Upgrading to vRealize Automation 7.3 appliance fails while running post-install scripts.
     
  • You see this issue while upgrading from vRA 6.2.x, 7.1, 7.2 to vRA 7.3.
     
  • In the updatecli.log file, you see entries similar to:
error: unpacking of archive failed on file /usr/ssl/certs: cpio: rename failed - Is a directory

And

+ echo '<YYYY-MM-DD>T<time> /etc/bootstrap/postupdate.d/00-00-rpm-status-check starting...'</time>

+ /etc/bootstrap/postupdate.d/00-00-rpm-status-check 7.2.0.381 7.3.0.536 4 + res=1 + echo 'Script /etc/bootstrap/postupdate.d/00-00-rpm-status-check failed, error status 1' + exit 1 + exit 1 + trapfunc + excode=1 + test 1 -gt 0 + vami_update_msg set post-install 'Post-install: failed' + test -x /usr/sbin/vami-update-msg + /usr/sbin/vami-update-msg set post-install 'Post-install: failed' + sleep 1 + test 1 -gt 0 -o 4 -gt 0 + vami_update_msg set update-status 'Update failed (code 4-1). Check logs in /opt/vmware/var/log/vami or retry update later.' + test -x /usr/sbin/vami-update-msg + /usr/sbin/vami-update-msg set update-status 'Update failed (code 4-1). Check logs in /opt/vmware/var/log/vami or retry update later.' + exit <YYYY-MM-DD>T<time> [ERROR] Failed with exit code 256</time>
  • In the vRA Appliance, the folder /usr/ssl/certs/ already exists.


Cause

This issue occurs due to the /usr/ssl/certs/ folder which is not expected under normal circumstances and causes the upgrade to fail initially. This folder may exist if the environment has configured vRealize Log Insight to communicate with a system that does not use self-signed certificates.

Resolution

This issue is resolved in VMware vRealize Automation 7.4, available at VMware Downloads.
 
To work around this issue,
  1. Re-run the upgrade a second time and it should allow for completion.
     
  2. If re-running the upgrade does not resolve the issue:
     
    1. Backup the directory by moving the files from /usr/ssl/certs to /etc/ssl/certs.
    2. Delete the directory and try again.
       
  3. If the issue still persists, please contact VMware's Global Support Services for further assistance. For more information, see How to file a Support Request in Customer Connect (2006985).