Problem:
Logging into APM Team Center results in a blank page.
Symptoms:
1. Receiving the below error message on the APM Team Center Page:
Error reading data from polling URL: ../apm/appmap/private/permission. Retrying in 60000ms. Attempt 3
Error retrieving permissions. Status code: 503
2. Below error is traced in IntroscopeWebView log.
[ERROR] [WebView] Unable to establish connection with remote resource at http://localhost:8081/apm/appmap/private/configuration/static!
java.net.ConnectException: Connection refused: connect
Environment:
Upgraded from APM 9.5.x to APM 10.1
Upgraded from APM 9.6.x to APM 10.1
Cause:
The APM 10.1 upgrade process fails to update the IntroscopeWebview.properties with the appmap port information in the property
"introscope.webview.enterprisemanager.rest.base" and then enable it.
Workaround: