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Article ID: 328453
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Issue/Introduction
Symptoms:
When performing a test failover or fail over operation in VMware vCenter Site Recovery Manager (SRM), you experience these symptoms:
- Test failover fails to complete
- Failover fails to complete
- Guest customization fails during the Changing Network Settings step
- You see one or more of these errors:
- Timed Out
- Error - Timed out waiting for Customization scripts to complete in 600 seconds. IP settings may have been partially applied.
- Error: Timed out waiting for VMware Tools after 300 seconds
Cause
This issue may occur if the network settings for the virtual machine’s guest operating system is customized as a part of recovery. This error indicates that the virtual machine failed to report the new network settings within the default timeout period of 300 seconds.
Resolution
To troubleshoot and resolve this issue:
- Ensure that the latest version of VMware Tools is installed on all protected virtual machines. VMware Tools is required for IP customization. For more information, see Verifying a VMware Tools build version (1003947).
- IP customization does not work on bubble network (portgroup with no network cards). Ensure that you choose a recovery network.
- Edit the recovery plan and increase the Change Network Settings timeout value. The default value is 300 seconds and the maximum is 900 seconds.
For specific virtual machines showing the error:
- Right-click virtual machine in the recovery plan and select Configure.
- Go to Startup Action > Power On > Wait for VMware tools.
- Change from the default value of 5 minutes to 15 minutes.
- If you see this message:
Error - Timed out waiting for Customization scripts to complete in 600 seconds. IP settings may have been partially applied.
Modify the value of the recovery.customizationTimeout parameter from the default value of 600 to a higher value.
To reset the value of the recovery.customizationTimeout parameter:
- Right-click the site and click Advanced Settings > Recovery.
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Modify the value of the recovery.customizationTimeout parameter from the default value of 600 to a higher value.
Notes:
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The minimum and maximum allowed values are 0 and 2147483647 respectively.
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Repeat this step for other site also.
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You must restart SRM services on both sites for the changes to take effect.
- If the virtual machine is configured as a DHCP client, verify that a DHCP server is available on the recovery network.
- If the virtual machine is configured with a static IP address, ensure that the address is available and is not in use on the recovery network.
- For more information about the errors that prevented the failover or test failover operation from completing, review the log files created by the customization process on each virtual machine.
The log files are located at:
- Windows virtual machines – C:\windows\temp\vmware-imc\toolsDeployPkg.txtIn
- Linux virtual machines – /var/log/vmware-imc/toolsDeployPkg.txt
- vCenter Server at the recovery site may be attempting to power on too many virtual machines at the same time. For more information, see Powering on many virtual machines simultaneously on the recovery site can lead to errors (2010593).
Note: If the problem still exists after trying the steps in this article: