Updating an allocation file terminates vRealize Cloud licenses from vRSLCM
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Updating an allocation file terminates vRealize Cloud licenses from vRSLCM

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Article ID: 328409

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  1. Performing Customer Connect resgistration within vRSLCM, all the vRealize Cloud licenses belonging to the registered account are downloaded and saved in vRSLCM locker.
  2. The vRealize Cloud licenses needs an allocation file for them to be activated.
  3. After applying a correct allocation file to the vRC licenses, they are terminated from the products (where they were applied from vRSLCM) upon a re-sync from Customer Connect.
Note: The re-sync can be due to scheduled task running in vRSLCM or due to manual invoke via the Refresh button present in vRSLCM locker UI under the License section.

Cause

This is caused by a known issue in vRSLCM.

Resolution

There is no resolution.

Workaround:
To workaround this issue on the vRSLCM versions 8.2GA or earlier, the following can be performed:
  1. If the license are already present in vRSLCM(downloaded from Customer Connect), perform a refresh on the licenses from vRSLCM locker (this will remove the downloaded licenses from all products where they were applied).
  2. Remove the licenses from vRSLCM locker UI by deleting them.
  3. Click on the API link from vRSLCM UI (this shows up if we click the logged in user-name).
  4. Execute the API /lcm/locker/api/v2/license/validate-and-add from under Locker License Controller. For the payload provide a name for the 'alias' (for easy identification in vRSLCM locker) and the license key against 'serialKey'.
  5. Repeat this API call for each license keys separately.
  6. Import the allocation file for the newly added flex license key.
  7. Once the license(s) is(are) added successfully, we can then apply to the products from vRSLCM.