Unable to see all the vCenter Port Groups in vRA reservations after successful data collection
search cancel

Unable to see all the vCenter Port Groups in vRA reservations after successful data collection

book

Article ID: 328387

calendar_today

Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • After successful data collection of vCenter Endpoint, not all the vCenter port groups are seen in vRA Reservations.
  • When we create a new vSphere (vCenter) Reservations, under Network tab, not all the vCenter port groups are populated.


Cause

  • This is a known issue with vCenter Server prior to version 6.0 Update 3 as it fails to handle addition of hosts to DV switch which already have a proxy switch with same UUID.
  • Improper removal of host from Inventory is one of the reasons for this to be exposed. VMware vCenter Server 6.0 Update 3 or later have an enhancement to address this sync issues.
  • This issue can also cause if we export/import DV Switch configuration.

Resolution

To resolve the issue, upgrade to vCenter Server to version 6.0 Update 3 or later available at VMware downloads. This would provide a relief to address the improper removal of the hosts from vCenter Inventory. System should be able to converge without manual intervention in cases where such host removal/addition is performed.

To workaround this issue if you do not want to upgrade:

Using the vCenter Server MOB, find the cluster object domain-cNN. Look at each host-NNN managed object in that cluster. In the network property, you will see a list of networks that are configured on that host. If a host or hosts are missing some networks which should actually be listed.
Follow the below procedure on affected host/hosts:
  1. The problematic host has to be fixed manually to remove the inconsistency.
  2. Migrate any VMs running on the host.
  3. Create a standard switch and migrate all the Networks and vmk NICs from DV Switch to the standard switch.
  4. Remove the host from vCenter Inventory.
  5. Delete the offending DV Switch proxy from the host by connecting directly to the host.
  6. Add back the host to vCenter and then to DV Switch.
  7. Run the data collection on vRA.


Additional Information

Steps to reproduce the issue:

  1. Add a host to DV Switch.
  2. Create a vmk nic or powered on VM and connect to the DV Switch.
  3. Disconnect the host from vCenter.
  4. Remove the host from vCenter inventory.
  5. Add the host to vCenter back.
  6. Add the host to the DV Switch back.
This information is part of the Release Notes of vCenter Server 6.0 Update 3 ( Refer to: Networking Issues under Resolved section of the release notes).Disabling vNetwork Distributed Switches
Attempting to remove a host from the inventory when it is connected to vDS generates an error