VMware Identity Manager integration fails with Incorrect username or password in vRealize Log Insight 4.x
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VMware Identity Manager integration fails with Incorrect username or password in vRealize Log Insight 4.x

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Article ID: 328365

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • Attempting to enable VMware Identity Manager authentication in vRealize Log Insight fails with the error Incorrect username or password.
  • Attempting to update the VMware Identity Manager authentication in vRealize Log Insight fails with the error Incorrect username or password.
  • The provided password contains a backslash (\) or other special character.


Cause

Credentials provided to the VMware Identity Manager REST API are passed in JSON format as a string and are not properly escaped.

This causes a password with a special character, such as \ to effectively skip the special character.
So a password of pass\word would be seen by VMware Identity Manager as password without proper encoding.

Resolution

This is a known issue affecting vRealize Log Insight 4.3.x - 4.6.x.
This issue is resolved in vRealize Log Insight 4.7, available at VMware Downloads.

Workaround:
To work around this issue, escape any needed backslash with a backslash proceeding it.

Example: If your password is pass\word, type pass\\word to to escape the needed backslash.