Cannot login to or manage vCenter SQL Express instance (VIM_SQLEXP) running on VMware vCenter Server
searchcancel
Cannot login to or manage vCenter SQL Express instance (VIM_SQLEXP) running on VMware vCenter Server
book
Article ID: 328267
calendar_today
Updated On: 11-04-2024
Products
VMware vCenter Server
Issue/Introduction
Cannot login to or manage the Microsoft SQL Server Express instance VIM_SQLEXP.
Using Microsoft SQL Management Studio, you are unable to login or manage the Microsoft SQL Server Express instance VIM_SQLEXP.
Cause
This issue occurs when the user account used during the initial install of vCenter Server has been deleted or no longer exists.
If Microsoft SQL Server Express is installed through the vCenter Server installation process, the currently logged in user is assigned administrative rights to the VIM_SQLEXP instance. If the user is deleted or no longer exists, no users will have administrative rights to manage this SQL Server instance by default.
Resolution
To resolve this issue, assign administrative rights to the currently logged in user in the VIM_SQLEXP instance using the steps below.
Download the 2063510_addselftosqlsysadmin.zip file attached to this article.
Extract the addselftosqlsysadmin.cmd script from the downloaded zip file.
Log in to the system in which the VIM_SQLEXP instance resides.
Run the addselftosqlsysadmin.cmd script as Administrator.
Follow the prompts within the script.
When prompted for the database instance name, run the command:
VIM_SQLEXP
This command assigns the System Administrator rights to the currently logged in user specified in Microsoft SQL Server Express instance.
Additional Information
Management can be performed later by using SQL Management Studio Express.