[Internal] Webclient login stuck at authenticating and does not progress
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[Internal] Webclient login stuck at authenticating and does not progress

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Article ID: 328176

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Updated On:

Products

VMware vCenter Server 7.0 VMware vCenter Server 8.0

Issue/Introduction

Symptoms:

  • Logging into the vCenter webclient fails at authentication, with any credentials.
  • This issue happens with any user account.
  • In the vsphere_client_virgo.log file located in /var/log/vmware/vsphere-ui/logs, entries similar to the following are seen:

    [INFO ] vc-service-pool-3 o.e.gemini.web.tomcat.internal.loading.BundleWebappClassLoader Illegal access: this web application instance has been stopped already. Could not load org.eclipse.gemini.web.tomcat.internal.loading.BundleWebappClassLoader. The eventual following stack trace is caused by an error thrown for debugging purposes as well as to attempt to terminate the thread which caused the illegal access, and has no functional impact. java.lang.IllegalStateException: null

[INFO ] vc-service-pool-3 o.e.gemini.web.tomcat.internal.loading.BundleWebappClassLoader Illegal access: this web application instance has been stopped already. Could not load org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader. The eventual following stack trace is caused by an error thrown for debugging purposes as well as to attempt to terminate the thread which caused the illegal access, and has no functional impact
java.lang.IllegalStateException: null
 

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on the environment.

Environment

VMware vCenter Server 7.x

VMware vCenter Server 8.x

Cause

Illegal access errors cause the delay in logging in.

Resolution

To resolve this issue, increase the webclient timeout value in vCenter Server Appliance.
 
To increase the webclient timeout value in vCenter Server Appliance:
  1. Log in to vCenter appliance appliance through SSH or console
  2. Navigate to:

    /etc/vmware/vsphere-client
     
  3. Take a backup copy of webclient.properties file.

    cp webclient.properties webclient.properties.bkp
     
  4. Open the webclient.properties file using text editor.
  5. Change the value of dataservice.timeoutSeconds = 360, which is set to 120 (default).
  6. Save and close the file.
  7. Run this command to restart the virgo service:

    service-control --restart vsphere-ui