Logging in to VMware vCenter Server 5.5 using the Web Client fails with the error: An internal error has occurred - Error #1009
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Logging in to VMware vCenter Server 5.5 using the Web Client fails with the error: An internal error has occurred - Error #1009

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Article ID: 327963

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:
  • Logging in to VMware vCenter Server using the vSphere Web Client fails after successfully upgrading to vCenter Server 5.5 with a pop-up error similar to:

    An internal error has occurred - Error #1009

  • The error stack has entries similar to:

    TypeError: Error #1009
    at com.vmware.opsmgmt.client.views.vcops.filters::VcopsViewsFilter/hasVcopsVappsDeployed()

    at com.vmware.opsmgmt.client.views.vcops.filters::VcopsViewsFilter/filterExtensions()

    at com.vmware.opsmgmt.client.views.vcops.filters::VcopsViewsFilter/onViewVisibleResult()

    at com.vmware.opsmgmt.client.views.vcops.filters::ViewMetadataManager/invokeCallback()

    at com.vmware.opsmgmt.client.views.vcops.filters::ViewMetadataManager/invokeCallbacks()

    at com.vmware.opsmgmt.client.views.vcops.filters::ViewMetadataManager/onDataRetrieved()

    at com.vmware.flexutil.proxies::BaseProxy/notify()
    at com.vmware.flexutil.proxies::BaseProxy/result()

  • In the C:\ProgramData\VMware\vSphere Web Client\serviceability\logs/vsphere_client_virgo.log file, you see entries similar to:


    [<time>][ERROR]data-service-pool-12359 70006698 100059 200018 com.vmware.opsmgmt.vcops.impl.VcopsDataAdapter Failed to retrieve VcopsInstallationMetadata information. java.lang.StringIndexOutOfBoundsException: String index out of range: -1
    at java.lang.String.substring(Unknown Source)</time>
    at com.vmware.opsmgmt.vcops.impl.VcopsVappInfoRetriverImpl.buildVcopsVappData(VcopsVappInfoRetriverImpl.java:184)
    at com.vmware.opsmgmt.vcops.impl.VcopsVappInfoRetriverImpl.extractVcopsVapps(VcopsVappInfoRetriverImpl.java:114)
    at com.vmware.opsmgmt.vcops.impl.VcopsVappInfoRetriverImpl.getVcopsVapps(VcopsVappInfoRetriverImpl.java:77)

  • In the C:\ProgramData\VMware\CIS\logs\vmware-sso\vmware-sts-idmd.log file, you see entries similar to:


    [<time>],919 INFO [IdentityManager] Authentication succeeded for user [ditex-manage-ek] in tenant [vsphere.local] in [45] milliseconds</time>

    [<time>],311 ERROR [IdentityManager] Failed to authenticate principal [VCPluginAdmin] for tenant [vsphere.local]</time>

    [<time>],331 ERROR [IdentityManager] Failed to checkUserAccountFlags principal [VCPluginAdmin] for tenant [vsphere.local]</time>

    [<time>],331 ERROR [ServerUtils] Exception 'com.vmware.identity.idm.IDMLoginException: Login failed'</time>

    com.vmware.identity.idm.IDMLoginException: Login failed

    at com.vmware.identity.idm.server.IdentityManager.authenticate(IdentityManager.java:2334)


  • In the C:\ProgramData\VMware\VMware VirtualCenter\Logs\vpxd.log file, you see entries similar to:

    <YYYY-MM-DD>T<time>[01520 info 'Default' opID=151e16a4] [VpxLRO] -- ERROR task-internal-917630 -- -- vim.SessionManager.login: vim.fault.InvalidLogin:</time>
    --> Result:
    --> (vim.fault.InvalidLogin) {
    --> dynamicType = <unset>,
    --> faultCause = (vmodl.MethodFault) null,
    --> msg = "",
    --> }
    --> Args:
    -->


Cause

This issue occurs due to an invalid Application URL associated with the vApp.

Resolution

This issue is resolved in vCenter Server 5.5 Update 2, available at VMware Downloads. For more information, see the Resolved Issues section in the vCenter Server 5.5 Update 2 Release Notes.

To work around this issue, perform one of these options:
  • Edit the settings of each vApp and ensure the Application URL in the Advanced Settings windows is valid as per this specification VMware vSphere 5.1 API Reference guide.
  • Close the pop-up window where the error appears, which allows the log in to complete with full functionality of the Web Client.
  • To install and remove the web client, perform these steps:

    1. Stop the web client services on the machine where the vSphere Web Client is installed, usually on the vCenter Server machine.
    2. Uninstall the vSphere Web Client.
    3. Delete the folder: C:\ProgramData\VMware\vSphere Web Client 4.
    4. Install the vSphere Web Client.
    5. Check the plug-ins.


Additional Information

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Web Client を使用して VMware vCenter Server 5.5 にログインすると次のエラーで失敗する:内部エラーが発生しました - エラー #1009
使用 Web Client 登录 VMware vCenter Server 5.5 失败并显示以下错误:出现内部错误 - 错误 #1009