VMware vCenter Server shows a stale vSphere standard port group, which is no longer in use
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VMware vCenter Server shows a stale vSphere standard port group, which is no longer in use

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Article ID: 327922

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • VMware vCenter Server shows a stale vSphere standard port group.
  • A standard port, which is deleted from all associated hosts in the vCenter Server is still visible.
  • The Standard port group appears under Home > Inventory > Networking in the vSphere Client.
  • The Standard port group also appears under the VM(s) summary page in vCenter. 


Environment

ESXi 8.0x 

 

Cause

This issue occurs if a snapshot was taken on a virtual machine when the vSphere standard port group existed, but has since been deleted.

This could also occur, if VM template(s) still exist, that were created when the VM(s) were on the original standard port group which have since been deleted, or no longer associated with the VM(s). 

Resolution

To resolve this issue, delete the snapshot from the virtual machine.
 
To delete the snapshot:
  1. Navigate to Home > Inventory > Networking in the vSphere Client.
  2. Select the stale standard port group that is deleted and not in use by any virtual machine.
  3. Click the Virtual Machines tab, identify the virtual machine that has snapshot and delete the snapshot.
  4. After identifying the virtual machines with snapshots and deleting them, the stale entry of standard port group should be cleared.

If snapshots are removed from the VM, and still, original standard port groups are still displaying, check for VM templates, and remove them. 

To remove VM template(s): 

1. Right click the template and select 'Delete from Disk' or 'Remove from Inventory'. 



Additional Information