Server 2008 patch deployments fail with the error: WUSA.exe Access Denied
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Server 2008 patch deployments fail with the error: WUSA.exe Access Denied

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Article ID: 327884

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Updated On:

Products

VMware

Issue/Introduction

This article provides a solution for WUSA.exe Access Denied errors when deploying patches.

Symptoms:
  • Server 2008 patch deployments fail on servers with HTTP agents.
  • Patch deployment jobs report success even though patch does not install.
  • In the Windows Setup event log on the target system, you see an error similar to:

    Windows update could not be installed because of error 2147942405"Access is denied." (Command line: ""C:\Windows\System32\wusa.exe"
    C:\Windows\SYSWOW64\CSISUMRCAgent\Windows6.1-KB2476490-x64.msu /quiet/norestart")


Cause

This issue occurs because the machine_connection_http_port entries in the database are not set correctly (they are set to NULL instead of the port number). This is most commonly caused by switching an agent from DCOM to HTTP and the database entries are not updated correctly.

Resolution

For assistance with this issue & required SQL scripts, file a support request with VMware Support and note this KB Article ID (2008300) in the problem description. For more information, see Filing a Support Request in Customer Connect (2006985).


Additional Information

How to file a Support Request in Customer Connect