SMARTS utility sm_snmpwalk times out
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SMARTS utility sm_snmpwalk times out

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Article ID: 327752

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:


SMARTS utility sm_snmpwalk times out

sm_snmpwalk times out

Environment

VMware Smart Assurance - SMARTS

Cause

Not getting a timely response back from the SNMP agent on the device

Resolution

First, check if it is a Counter-64 problem.  This can be checked by running the following command:

<BASEDIR>/IP/smarts/bin/sm_snmpwalk -o .1.3.6.1.2.1.1.31.1.1.1.6 <HOST>

Things to check when timeout occurs:

  • Is correct community string being used
  • Is correct IP address specified
  • Is correct port used, i.e. if snmp agent is running on port other then 161.
  • Do devices have access control list which is not allowing the machine where AM resides to do a snmp request.