Smarts: The OID .1.3.6.1.2.1.1.4.0 is not being returned by the SNMP Agent.
search cancel

Smarts: The OID .1.3.6.1.2.1.1.4.0 is not being returned by the SNMP Agent.

book

Article ID: 327704

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




Smarts: The OID .1.3.6.1.2.1.1.4.0 is not being returned by the SNMP Agent
Error:

[18-Apr-2007 17:23:49+790ms EDT] t@65 AD_CallbackSNMP #1
ADTM-W-TMG2_BAD_VALUE_IN_SNMP_RESPONSE-Bad value in SNMP response for OID
    '.1.3.6.1.2.1.1.4.0' : 'noSuchObject' for IP Address '172.17.12.29, port
    161'



Environment

VMware Smart Assurance - SMARTS

Cause

For Smarts to successfully communicate with the SNMP agent, the OID values listed in the Fix statement of this solution have to be setup by the Network Administrator on the discovery candidate so that they will respond to SNMP. 

"Phase 1: Perform initial polling of the candidate system" in the IP Discovery documentation included with the Smarts installation explains the OID used to determine an SNMP device. This document is installed with Smarts at the following location:

<BASEDIR>/IP/doc/pdf/ip_discovery.pdf  

Resolution

To resolve this issue, have the Network Administrator set up the following OIDs on the discovery candidate so that Smarts can successfully communicate with the SNMP agent:

sysName - .1.3.6.1.2.1.1.5
sysDescr - .1.3.6.1.2.1.1.1
sysObjectID - .1.3.6.1.2.1.1.2
sysContact - .1.3.6.1.2.1.1.4
sysLocation - .1.3.6.1.2.1.1.6