Smarts IP: Interface adminstatus and operstatus NOTPRESENT in smarts IP Availability Manager
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Smarts IP: Interface adminstatus and operstatus NOTPRESENT in smarts IP Availability Manager

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Article ID: 327688

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Updated On:

Products

VMware

Issue/Introduction

Symptoms:




Interface adminstatus and operstatus NOTPRESENT in smarts IP Availability Manager
Interface is up, but Smarts is generating a Interface Down event

Environment

VMware Smart Assurance - SMARTS

Cause

This problem can be caused by the devices SNMP agent not populating the information into the OIDS or There is a duplicate IP address in the network.

Resolution

The interface index ID (ifIndex) does not have data populated to ifIndex ID on the device's SNMP agent for the AdminStatus and OperStatus OIDs.
 
To verify that this is the cause, complete the following actions:
  1. In the Topology Browser, check the InterfaceNumber setting.
     
  2. Match the InterfaceNumber setting in the Topology Browser against the ifIndex ID found during an SNMP walk of the device at .1.3.6.1.2.1.2.2.1.1.ifIndexID: ifIndex ID To gather the walk, use the sm_snmpwalk utility located in IP/smarts/bin.
     
  3. Check the SNMP walk or mimic file that is created to see if the ifIndex ID has legitimate values on the AdminStatus OID .1.3.6.1.2.1.2.2.1.7.ifIndexID: {1,2,3} and OperStatus OID .1.3.6.1.2.1.2.2.1.8.ifIndexID: {1,2,3}
  4. if the value of these oids is not 1,2, or 3, then the smarts software will report NOTPRESENT due to the SNMP agent not presenting valid data
  5. This is means that the devices software is faulty and not reporting information properly. 

The above can also occur when there are duplicate IP address in the network.  To verify if this is the case, get the list of IP addresses in the AgentAddressList attribute of the SNMPAgent instance, then walk the System MIB to verify if any ip address is duplicated.  This can appen if the duplicated IP address or device is not part of the topology.  Example:

  1.  <BASEDIR>/IP/smarts/bin/dmctl -s INCHARGE-AM-PM get SNMPAgent::SNMPAgent-Router1::AgentAddressList
  2. <BASEDIR>/IP/smarts/bin/sm_snmp -d <device name/ip? -c <community string> -s <snmp version > walk .1.3.6.1.2.1.1
  3. Check the output of System MIB on every ip address to verify if they are all the same.   If they are not the same, then NOTPRESENT status can occur when the IP domain is polling the wrong device.

 


Additional Information

SNMP mimic or walk files can be created with the following command and this can also be used to verify the Interface number.

IP/smarts/bin/sm_snmpwalk -c <community string> -d <device name> 

This command will create the following three files in the current directory:
 
<device name>.mimic
<device name>.walk
<device name>.snap