Ionix SAM/Smarts SAM: In Windows environment, certain set parameters are not being passed to the Service Assurance Manager (SAM) Client tools
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Ionix SAM/Smarts SAM: In Windows environment, certain set parameters are not being passed to the Service Assurance Manager (SAM) Client tools

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Article ID: 327673

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

Symptoms:




Certain set parameters in Windows environment are not being passed to the Ionix SAM/Smarts SAM Service Assurance Manager (SAM) Client tools
If I set the parameters to a variable in my Windows environment and then echo the variable within my script, the echo returns nothing to the Ionix SAM/Smarts SAM Service Assurance Manager (SAM) Client tools

Environment

VMware Smart Assurance - SMARTS

Cause

The parameter variables are not being passed into the client tool because in Windows, the use of the Runtime exec method and passing parameters on the command line does not work very well. The above problem symptoms can happen on any version of the Windows OS, and are not specific to a single version of Windows.

Resolution

To resolve this issue, set the following as part of the client console startup options:

sm_gui -Dcom.smarts.clientTool.setEnv=true

This can also be set in the properties.conf file located in the <BASEDIR>\conf\console directory as follows:

com.smarts.clientTool.setEnv=true

The above flag will set the environment variable so that when you call the variable, it will pull out the correct information.