Unexpected error while searching the database according to search criteria
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Unexpected error while searching the database according to search criteria

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Article ID: 32761

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Updated On:

Products

CA Virtual Privilege Manager CA Privileged Identity Management Endpoint (PIM) CA Privileged Access Manager - Server Control (PAMSC)

Issue/Introduction

Upon any search in World View, the following error message appears:
“Error: Unexpected error while searching the database according to search criteria” 

When looking at the JBoss/Wildfly logs, the following error is seen:
2015-10-20 17:24:01,530 ERROR [com.ca.accesscontrol.policy.core.webservice.BackendSessionManager] error connecting to DMS: host name: DMS__@localhost, user name: ac_entm_pers
com.ca.accesscontrol.policy.core.exception.ACException: Connection to host DMS__@localhost using user name: ac_entm_pers has failed with the returned error: (DMS__@localhost)
ERROR: Login procedure failed
ERROR: Password on target does not match client's password

Environment

PIM Enterprise Management 12.8 and above
PAMSC Enterprise Management 14.0 and above

 

Cause

This will happen when there is an issue with the ac_entm_pers account used by ENTM to access the DMS.

Resolution

First, connect to the DMS and verify the user exists.
# selang
AC> host DMS__@
(DMS__@localhost)
Successfully connected
AC> su ac_entm_pers
(DMS__@localhost)
Data for USER 'ac_entm_pers'
.....

If the user exists and its current password is known, log into Enterprise Management and go to System > Connection Management > Modify Connection to update the password in the UI.

If the user exists and its password is unknown, change the password in the DMS and set it in the UI to match the new password.

Additional Information

For information on how to update the ac_entm_pers password, please refer to this section of the documentation.