Security Error: Database error [CMM001300]
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Security Error: Database error [CMM001300]

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Article ID: 32747

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Updated On: 03-20-2025

Products

CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Software Delivery

Issue/Introduction

In DSM Explorer when updating the permissions of a Security Profile, following error appears after a timeout of 10 minutes :

 

Security Error: Database error [CMM001300]

 

This error only occurs for the class "Asset Group", others classes could be updated without problem.

Environment

CA Client Automation 

 

Cause

When the permissions on class "Asset Group" are updated, a lot of SQL requests are executed in order to update all the groups in the MDB database.

This could take several minutes if there are a lot of groups in the database.

Sometimes the execution time of the SQL requests could exceed 10 minutes. In this case, a timeout occurs and the SQL requests are roll-backed.

 

Resolution

On the Client Automation Domain Manager execute the following command in order to increase the timeout value (default value is 10 minutes).

 

For Example to set a timeout of 20 minutes:

ccnfcmda -cmd SetParameterValue -ps itrm/database -pn CommandTimeout -v 20

Try again to update the Permissions of the "Asset Group" class.

 

If this does not work, permissions can be set directly in the MDB database using a SQL Query. For Example:

use mdb

UPDATE ca_class_ace

SET ace = 255, access = 1

WHERE security_profile_uuid = (select security_profile_uuid from ca_security_profile where name='security_profile_name')

AND (class_def_uuid = (select class_def_uuid from ca_security_class_def where class_id=7000))

 

Replace security_profile_name with the name of the Security Profile to updated.