During the Data Protection enablement process, the TMC console continues to show "Data protection is being enabled"
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During the Data Protection enablement process, the TMC console continues to show "Data protection is being enabled"

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Article ID: 327450

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Updated On:

Products

VMware

Issue/Introduction

Provide the command to remove Data Protection using the tmc CLI.

Symptoms:
In the TMC Console, your cluster continues to show "Data protection is being enabled" state.

Cause

This can happen where events within the cluster infrastructure have occurred that disrupt the initialization of Data Protection.  Such as issues with a 3rd-party s3-compatible storage, or firewalls.

Resolution

  • Login through the tmc cli
  • From the TMC Console, go to Clusters -> CLUSTER_NAME
  • Confirm the name of the Management cluster
  • Confirm the name of the Provisioner
  • Run the tmc command to remove Data Protection.
NOTE: an directly attached cluster would have attached for Management cluster and Provisioner

Example:

tmc cluster dataprotection delete --cluster-name CLUSTER_NAME --management-cluster-name attached --provisioner-name attached