Rsyslog service failed to start, post upgrading VMware Aria Suite Lifecycle from version 8.10 to 8.12
search cancel

Rsyslog service failed to start, post upgrading VMware Aria Suite Lifecycle from version 8.10 to 8.12

book

Article ID: 327433

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

To be aware of the Rsyslog service failure post upgrade

Symptoms:
Upon verifying the Rsyslog service status as health check post upgrade, below errors are found:

Below log excerpts are from internal lab:
-----------------------------------------------------
root@Testlcm [ ~ ]# systemctl status rsyslog.service
● rsyslog.service - System Logging Service
   Loaded: loaded (/lib/systemd/system/rsyslog.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2023-08-09 05:14:05 UTC; 6h ago
     Docs: man:rsyslogd(8)
           https://www.rsyslog.com/doc/
 Main PID: 1002 (code=exited, status=1/FAILURE)

Aug 09 05:14:05 Testlcm.org systemd[1]: Failed to start System Logging Service.
Aug 09 05:14:05 Testlcm.org systemd[1]: rsyslog.service: Service RestartSec=100ms expired, scheduling restart.
Aug 09 05:14:05 Testlcm.org systemd[1]: rsyslog.service: Scheduled restart job, restart counter is at 5.
Aug 09 05:14:05 Testlcm.org systemd[1]: Stopped System Logging Service.
Aug 09 05:14:05 Testlcm.org systemd[1]: rsyslog.service: Start request repeated too quickly.
Aug 09 05:14:05 Testlcm.org systemd[1]: rsyslog.service: Failed with result 'exit-code'.

Environment

VMware Aria Automation 8.12.x
VMware vRealize Suite Lifecycle Manager 8.10.x

Cause

During upgrade process, existing rsyslog configuration gets overwritten.

Resolution

This is a known issue and it will be fixed in future release. 

Workaround:
1. Restore the old configuration 
    mv /etc/rsyslog.conf.old /etc/rsyslog.conf

2. Start the service
    systemctl start rsyslog.service

Additional Information

Impact/Risks:
Rsylog service fails to start due to which upgrade to future versions will fail eventually.