Reports are not being de-anonymized using the de-anonymization script for Usage Meter 4.3
search cancel

Reports are not being de-anonymized using the de-anonymization script for Usage Meter 4.3

book

Article ID: 327425

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

To fix the duplicate entries in the Usage Meter report so that the de-anonymization script works properly.

Symptoms:
When you try to de-anonymize the reports by following this document, from all fields of the Usage Meter report, only the VCHostName has been de-anonymized. The rest of the fields remain anonymized.

Environment

VMware vCloud Usage Meter 4.x

Cause

It's a known issue with Usage Meter 4.3, where the appliance gets corrupted and the de-anonymization script fails to de-anonymize the report.

Resolution

Procedure

To remove the duplicate entries in the Usage Meter report:
  1. Log in to Usage Meter 4.3 as usagemeter.
  2. Navigate to /opt/vmware/cloudusagemetering/var/dss/hash.
  3. Open the dss.hash file. Check the its records. There should be duplicated entries. The entries are similar to this example: {"inStr":"CentOS","v":2,"hash":"<hash_id>"}, where CentOS is the anonymized object.
vim dss.hash
  1. Remove the duplicated records.
:sort u
  1. Save the changes.
  2. Check the records. The duplicate records should have been removed.
  3. Execute the de-anonymization process. Once the above steps are executed, the de-anonymization script will correctly de-anonymize the report.