NSX-T Intelligence deployment stuck at message "The NSX Intelligence appliance deployment is in progress"
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NSX-T Intelligence deployment stuck at message "The NSX Intelligence appliance deployment is in progress"

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Article ID: 327369

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Updated On:

Products

VMware NSX Networking

Issue/Introduction

Symptoms:
  • NSX-T Intelligence deployment fails.
  • The deployment is stuck in this message similar to:

    The NSX Intelligence appliance deployment is in progress.


Environment

VMware NSX-T Data Center 2.5.x
VMware NSX-T Data Center

Cause

This issue occurs as only Base64-encoded certificate files are supported in NSX Intelligence 1.0.1. Extra attributes that are part of a PEM-encoded certificate are not allowed.

Resolution

To resolve this issue, VMware recommends to use a certificate that contains only Base64 encoding.

Workaround:
To work around this issue:
  1. Delete the NSX Intelligence appliance.

    a.    Log in to NSX Manager UI and navigate to Systems > Appliances.
    b.    Locate the NSX Intelligence appliance card and click Delete.
     
  2. Identify the certificates on the NSX Unified Appliance that contain Bag Attributes or non-Base64 characters.
  3. Copy the certificates you identified in step 2 above and remove the extra attributes/characters so that the certificates only contain items starting with the --- BEGIN CERTIFICATE --- line and ending with the -- END CERTIFICATE --- line.
  4. Upload the updated certificates. For more information, see the Import a Certificate section of the VMware NSX-T Data Center Administration Guide.
  5. Set the newly uploaded certificate as the node certificate or cluster certificate, as appropriate. For more information, see the Replace the Certificate for an NSX Manager Node or an NSX Manager Cluster Virtual IP section of the NSX-T Data Center Administration Guide.
  6. Delete the old certificates that contained the extra attributes/characters.
  7. From the NSX Manager User Interface (UI), navigate to Systems > Appliances, locate the NSX Intelligence card, and deploy the NSX Intelligence appliance again.
Note: If the above workaround does not resolve the issue, you may have to delete the NSX Intelligence appliance using direct REST API.
  1. Obtain the deployment ID (denoted by vm_id field in the API response) for the NSX Intelligence appliance:

    GET https://<NSXMGR_IP>/api/v1/intelligence/nodes/deployments
     
  2. Delete the NSX Intelligence appliance using the following API:

    POST https://<NSXMGR_IP>/api/v1/intelligence/nodes/deployments/<deployment_id_from_prev_step>?action=delete
     
  3. Deploy a new NSX Intelligence appliance and follow the steps in the KB above to resolve the issue.