Unable to download technical support bundle if locale is set to JP or KR
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Unable to download technical support bundle if locale is set to JP or KR

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Article ID: 327356

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Updated On:

Products

VMware NSX Networking

Issue/Introduction

Symptoms:
  1. When attempting to download NSX Tech Support Log, "Download" button does not appear and UI stucks with "Click the Generate button to start collecting log"..
  2. This Tab is missing
  3. Locale is configured to JP or KR.
  4. Appliance Management log can look like following:
2019-02-18 01:55:29.467 GMT ERROR https-jsse-nio-443-exec-1 VsmJsonErrorResolver:28 - - [nsxv@6876 comp="nsx-manager" errorCode="MP100" subcomp="manager"] Error discovered by JSON RPC com.vmware.vsmvam.common.exceptions.TechSupportBundleException: Error occurred while running tech support bundle script, no output file
To show appliance management logs, "show log appmgmt" is available on NSX Manager CLI.

Environment

VMware NSX for vSphere 6.4.x

Cause

NSX Manager Tech Support Log is generated by backend script. The script is unable to handle locale correctly.

Resolution

Currently, there is no resolution.

Workaround:
To workaround this issue, change locale from JP or KR and reboot NSX Manager appliance.
To change locale on NSX Manager GUI, navigate to Manage > General > Locale.