ログイン時または vCenter Server へのアクセス時に、vSphere Web Client で「503 サービスを使用できません (503 Service Unavailable)」というエラーが表示される
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ログイン時または vCenter Server へのアクセス時に、vSphere Web Client で「503 サービスを使用できません (503 Service Unavailable)」というエラーが表示される

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VMware vCenter Server

Issue/Introduction

この記事では、vSphere Web Client を使用した vCenter Server へのログイン時およびアクセス時に、このエラーが発生した場合の対処方法とトラブルシューティングの手順について説明します。

Symptoms:

  • vSphere Web Client を使用して vCenter Server または vCenter Server アプライアンス (VCSA) にログインすると失敗する。
  • vSphere Web Client を使用して vCenter Server または vCenter Server アプライアンスにアクセスすると失敗する。
  • 次のようなエラーが表示される。

    503 サービスを使用できません (503 Service Unavailable)
    503 Service Unavailable (Failed to connect to endpoint: [N7Vmacore4Http20NamedPipeServiceSpecE:0x00007fb7d00200a0] _serverNamespace = / action = Allow _pipeName =/var/run/vmware/vpxd-webserver-pipe)


:vCenter STS証明書は特定の構成で有効期限切れになる可能性が有り、STS証明書が有効期限切れにより失効すると、このKBに記載されている症状が発生します。以下のKBに記載の方法でSTS証明書の有効性を確認し、既に有効期限が切れている場合はSTS証明書を再生成してください。

Environment

VMware vCenter Server 6.0.x
VMware vCenter Server 6.5.x
VMware vCenter Server 6.7.x
VMware vCenter Server 7.0.x
VMware vCenter Server Appliance 6.0.x
VMware vCenter Server Appliance 6.5.x
VMware vCenter Server Appliance 6.7.x
VMware vCenter Server Appliance 7.0.x

Cause

この問題は、次のようなさまざまな理由で発生することがあります。

  • メンテナンスのため、vCenter Server が現在停止している。
  • vCenter Server のリバース プロキシ サービスが停止している。
  • vSphere Web Client サービスが停止している。
  • ファイアウォールが正しく設定されていない。

Resolution

トラブルシューティングを行う前に、「503 サービスを利用できません (503 Service Unavailable)」というエラーの意味を理解することが重要です 詳細については、「HTTP ステータス コードのリスト」および503 サービス利用不可のフロー チャート」を参照してください。「503 サービスを利用できません (503 Service Unavailable)」エラーはサーバが一時的にリクエストを処理できない状態であることを示す HTTP 応答ステータス コードです。これは、「Cause」セクションで述べたいくつかの原因によって発生します。

503 ページの表示は Web サイトによって異なることがあります。

例:

  • 503 Service Unavailable (Failed to connect to endpoint: [N7Vmacore4Http20NamedPipeServiceSpecE:0x00007fb7d00200a0] _serverNamespace = / action = Allow _pipeName =/var/run/vmware/vpxd-webserver-pipe)
  • 503 Error
  • Service Unavailable – DNS Failure
  • HTTP Error 503
  • HTTP 503
  • 503 Service Temporarily Available

503 エラーはサーバ側のエラーであることに注意してください。つまり、お使いのコンピュータまたは Web サイト(クライアント側)に問題があるのではなく、アクセス先の vCenter Server 側に問題があるという意味です。

vCenter Server に接続するときに vSphere Web Client の HTTP レスポンス ステータスコード「503」をトラブルシューティングする

  1. 数分待ってから再試行します。

    :vCenter Server がリクエストの認識のためにビジー状態になっている場合がほとんどです。vCenter Server はリクエストを処理することができています。また、「503 Service Unavailable (503 サービスを利用できません)」エラーで応答することもできています。これは、他のタスクでビジー状態になっているか、メンテナンスによる停止でサービスの利用が制限されていることが理由で、リクエストの認識ができない状態です。
  2. 別のクライアントで数分後に再試行します。同じエラーが引き続き表示されるかどうかを確認します。
  3. VMware vCenter サービスのステータスを確認します。必要なすべての vCenter Server サービスが起動し、機能していることを確認します。詳細については、以下を参照してください。
  1. vCenter Server または vCenter Server Appliance のディスク容量に問題ないかを確認します。

    :ディスク容量の問題は、1つ以上のサービスの停止を引き起こし、HTTP 503 エラーとなることがあります。ディスク容量の問題は、直接 HTTP 503 エラーの原因とはなりませんが、サービスの停止がこのエラーの原因となることがあります。以下を参照してください。
  1. 証明書が期限切れになっていないか確認します。
  2.  vCenter Server から、以下の場所にある vsphere_client_virgo.log ファイルを調べます。
    • Windows vCenter Server の場合:C:\ProgamData\VMware\vCenterServer\logs\vsphere-client\logs\
    • vCenter Server Appliance の場合:/var/log/vmware/vsphere-client/logs/
    • また、次の場所にある vpxd.log ファイルを確認します。
      • Windows vCenter Server の場合:C:\ProgramData\VMware\vCenterServer\logs\vmware-vpx
      • vCenter Server Appliance:/var/log/vmware/vpxd
       7. VMware vSphere 6.x/7.x における以下のパフォーマンスのベスト プラクティスを推奨します。

       8. VMware vCenter Server、vSphere Web Client、ストレージおよびネットワークのトラブルシューティングの詳細については、「VMware vSphere Troubleshooting Guide」を参照してください。  
 

トラブルシューティングワークフロー




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