VIC Plugin Does Not Load After Install
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VIC Plugin Does Not Load After Install

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Article ID: 327252

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
The VIC plugin installer script runs and reports successful. After restarting the web client services the VIC plugin does not load. The logs on the vCenter /var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log report error downloading the plugin zip. 
[2018-02-20T13:46:16.805-05:00] [WARN ] vc-extensionmanager-pool-62 com.vmware.vise.vim.extension.VcExtensionManager Package com.vmware.vic was not installed. Error downloading https://<VIC_Appliance_FQDN>:9443/files/com.vmware.vic-v1.3.0.533.zip. Make sure that the URL is reachable then logout/login to force another download.
[2018-02-20T13:46:16.805-05:00] [WARN ] vc-extensionmanager-pool-61 com.vmware.vise.vim.extension.VcExtensionManager Package com.vmware.vic.ui was not installed. Error downloading https://vpviclbal800.techlab.susq.com:9443/files/com.vmware.vic.ui-v1.3.0.533.zip. Make sure that the URL is reachable then logout/login to force another download.


Cause

The vCenter is being blocked from reaching the VIC Appliance over port 9443.

Resolution

The vCenter needs to be able to reach the VIC Appliance over port 9443. Typically there is a firewall in the network path placed between vCenter and the VIC Appliance. The admin for that firewall will need to configure the firewall to allow for this traffic to pass.