Symptoms: Wavefront customers have observed multiple issues related to misfiring Alerts and Alerts not firing as per window of time specified. The alert may trigger a firing condition or resolve from a firing condition when the data does not support the criteria to cause a change.
Cause
This issue occurs when there is a wildcard (*) expression in the alert condition.
Resolution
This is a known issue affecting Wavefront version 2018-22.x. The issue has been resolved in version 2018-26.XX and later.
Workaround: Modify the alert query so that there are no wildcard expressions included.