[VMC on AWS] HCX Appliance fails to start some services due to DNS resolution failure
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[VMC on AWS] HCX Appliance fails to start some services due to DNS resolution failure

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Article ID: 327143

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Updated On:

Products

VMware HCX VMware Cloud on AWS

Issue/Introduction

The document explains the cause for the HCX Connector not starting the HCX Appliance Management Interface when DNS resolution fails

Symptoms:
After deploying the HCX connector, accessing the HCX web page is not working because of a failure starting the App-engine service.

When viewing the VM Console from vSphere Client, these errors are shown.

[FAILED] Failed to start App-Engine.
[FAILED] Failed to start Appliance Management
[FAILED] Failed to start WebEngine


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Cause

When DNS resolving between HCX and the configured DNS server fails, the App-engine service, which is dependent on other services (appliance-management, web-engine), fails to start.
As a result, the HCX Appliance Management Interface cannot run and the services keep starting themselves.

Resolution

Resolve connectivity issues between HCX and the configured DNS server.
Please make sure nothing is blocking or dropping DNS requests.
  1.  The DNS server is not blank at the OVF deployment wizard and set the correct IP address.
  2. HCX appliance is attached to the virtual switch port group properly.
  3. Network connectivity from HCX to configured DNS server.
  4. Firewall rules allow the DNS packet