[VMC on AWS] Custom Chart Options in vSphere Client does not reflect Chart Type properly
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Article ID: 327125
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Updated On:
Products
VMware Cloud on AWS
Issue/Introduction
This article provides information for the known issue that Custom Chart Options in vSphere Client does not reflect Chart Type properly.
Symptoms: Even if you save the chart options for the Stacked Graph chart type in the Advanced Chart of the vSphere Client in VMware Cloud on AWS, when you load your custom chart options, the chart type becomes Line Graph.
Open vSphere Client in VMware Cloud on AWS with Cloud Admin account.
Select example VM from inventory browser, then proceed Monitor > Performance | Advanced.
Click Chart Options.
In the Chart Options menu, select Stacked Graph from Chart Type pull down.
Click SAVE OPTIONS AS... and save the custom Chart Option.
Click OK button and close the Chart Options menu. The graph in the chart will be stacked view.
Move other component view such as vCenter, and then back to the same advanced chart of the VM.
Select the custom chart option which is saved in "5." from View: pull down. The graph in the chart will be line view.
Click Chart Options. We can see that Chart Type is changed to Line Graph unexpectedly.
Select another Chart Option such as Default from the Chart options pull down, and then select the custom chart option again. The Chart Type is changed to Stacked Graph.
Cause
This is a known issue where vSphere Client is unable to show correct chart type in saved custom chart options.
Resolution
The VMware Engineering is aware of this known issue and is currently working on a resolution which will be part of a future release.
Workaround: If you see this behavior in your custom chart options, select another Chart Option such as "Default" from the "Chart options" pull down, and then select the custom Chart Option again.