[VMC on AWS] vCenter Cloud Gateway update fails
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[VMC on AWS] vCenter Cloud Gateway update fails

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Article ID: 327103

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

The following instruction will give a work-around to customers suffering with the given symptom.


Symptoms:

vCenter Cloud Gateway shows "Update [version number] is not found" when logging into console. 


Cause

With the past update session failing once, the "software_update_state.conf" file has its status changed to "INSTALL_FAILED", which suppresses the auto-update to run.

Resolution

1.Login to the vCGW via SSH and find the file "/etc/applmgmt/appliance/software_update_state.conf".

2. Open the file with the cat command.

3. Delete the line "operation_id": "/storage/core/software-update/stage_install_operation".

4. Edit and change the line ["state": "INSTALL_FAILED"] to ["state": "UP_TO_DATE"].

5. Delete the "," (comma) in the line "latest_query_time": "20xx-xx-xxTxx:xx:xxZ".

6. The expected line would look like:

 

{

   "state": "UP_TO_DATE",

   "version": "x.x.x.x",

   "latest_query_time": "20xx-xx-xxTxx:xx:xxZ"

}

 

7. No service restarts or updates are required. Login to the vCGW console UI and check that the error is gone.


Additional Information

Impact/Risks:

The customer cannot get their newest version of update for their vCenter Cloud Gateway.