Placing host into maintenance mode with 'Full data migration' option fails
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Placing host into maintenance mode with 'Full data migration' option fails

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Article ID: 327026

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:
Placing an ESXi host into maintenance mode through the Web Client and selecting the Full data migration option fails with the error message similar to:
A general system error occurred: Operation failed due to a vSAN error.
Failed to enter maintenance mode in the current vSAN data migration mode due to insufficient nodes or disks in the cluster. Retry operation in another mode or after adding more resources to the cluster.

Cause:
General vSAN error.

 
Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.
 


Environment

VMware vSAN 6.2.x
VMware vSAN 5.5.x
VMware vSAN 6.1.x
VMware vSAN 8.0.x
VMware vSAN 6.0.x
VMware vSAN 6.x
VMware vSAN 7.0.x

Cause

When selecting the Full data migration option, vSAN will try to evacuate all of the components that are currently hosted on that host. If any objects have a storage policy that will not be compliant after the host enters maintenance mode, the action will fail, as vSAN will always enforce the objects to be compliant to the policy (except when specified otherwise).

For Example: If you have 3 hosts and an object with failures to tolerate of 1, the minimum requirement to be compliant with this policy is 3 hosts. If you try to evacuate one host with maintenance mode, this will leave you with 2 active hosts, which is not enough to comply with the specified policy.

This rule also applies to the objects that are not currently registered in the inventory. For Example: If you have a virtual machine with a certain storage policy and you remove it from inventory, it will still be a known object on the vSAN datastore, which means vSAN still needs to keep it compliant. The same goes for the virtual disks for example that have been detached from the virtual machine.

Resolution

  • To resolve this issue, verify all virtual machines and virtual disks in the inventory have policies in use that are compliant after a single host failure.
  • Confirm that the DataStore has enough space 
  • Keep in mind the following good practices that we always remind our customers: use a minimum of FTT=1 for workloads that must remain online during maintenance activities and avoid using “No data migration” unless it is necessary
  • Run df -h 
  • Confirm what policy is the customer using and how many nodes are part of the cluster 


Workaround:
Also, check for Unassociated objects via. RVC. These objects might still reside on the vSAN datastore, but are not attached to a VM.

This will allow you to verify the type of object and its assigned policy. Attach these objects to Inventory in vSAN and change their policy or remove these objects if they are not needed anymore.

Additional Information