Creating/Cloning/Migrating a VM fails with error: "No VASA Provider for schema namespace (VSAN) found"
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Creating/Cloning/Migrating a VM fails with error: "No VASA Provider for schema namespace (VSAN) found"

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Article ID: 326993

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Updated On: 04-18-2025

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • Unable to create new virtual machine or create a virtual machine from a template.

  • In the vSphere Web client, you will not see any vSAN storage provider.

  • You will see error similar to:

A general system error occurred: PBM error occurred during PreCreateCheckCallback: pbm.fault;

No VASA Provider for schema namespace (VSAN) found

  • VM migration fails with such error,

A general system error occurred: PBM error occurred during PreMigrateCheckCallback: Fault cause: pbm.faultPBMFault;

No VASA Provider for schema namespace (VSAN) found

  • vSAN Storage Provider fails to synchronize and show error as below:

  • In some cases, you can see the vSAN storage provider but with an unknown status and on attempting to perform a synchronize of the vSAN storage provider, it would fail with a "Rescan" error. 


Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.



Environment

VMware vCenter Server 8.x
VMware vCenter Server 7.x
VMware vCenter Server 6.x

Cause

This issue occurs  when vCenter Server can not detect any vSAN storage provider.

There is no way to detect vSAN storage provider, If none of the hosts are available when vCenter Server starts.

The issue also occurs if vmware-vsan-health service is not running.



Note: vSAN storage provider cannot be recognized automatically even after host start working properly.

Resolution

To work around this issue, you have the following options.

  • Initiate synchronizing vSAN storage provider by clicking the icon for synchronization in the page:
vCenter Server > Configure > Storage Providers
  • Make sure at least one host is working when starting vCenter Server.

  • Ensure that the vmware-vsan-health service is up and running.

  • If vmware-vsan-health service is stopped, start it by the command "service-control --start vmware-vsan-health"
  • If vmware-vsan-health fails to start, please contact Broadcom Technical support and open a support request referencing this KB.

The VASA-related issue has been resolved in 6.7 U3 and 7.0 GA onwards.

Additional Information