vSAN performance diagnostics reports: "No benchmark seems to have run during the selected time period"
search cancel

vSAN performance diagnostics reports: "No benchmark seems to have run during the selected time period"

book

Article ID: 326960

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

This article explains the vSAN performance diagnostics issue No benchmark seems to have run during the selected time period and  possible solutions to address this issue.

Symptoms:
In vSAN performance diagnostics, you see a message similar to:

No benchmark seems to have run during the selected time period.

Environment

VMware vSAN 6.6.x
VMware vSAN 6.5.x
VMware vSAN 7.0.x
VMware vSAN 6.7.x

Cause

This message is an indicator that there were not enough I/Os per second (IOPS) in the selected time period to allow a performance diagnosis. This is usually when no vSAN workload has been running on the examined vSAN cluster.

Resolution

What are possible ways to address this issue?

It is possible that you have chosen an incorrect time period on which to do the analysis. Please select a time period during which some substantial workload or benchmark has been running on the vSAN cluster, and then run vSAN performance diagnostics again. VMware recommends that HCIBench be used as a benchmark to test vSAN.

Additional Information

For more information, see vSAN performance diagnostics.