The vSAN iSCSI target service may be interrupted if ESXi host agents are restarted
book
Article ID: 326906
calendar_today
Updated On:
Products
VMware vSAN
Issue/Introduction
Symptoms:
The vSAN iSCSI target service I/O could be interrupted and the service may not be started after restarting the ESXi host agents.
In the /var/run/log/vitd.log, you see similar to:
2020-01-01T05:55:55Z vitd: [etc/init.d/vitd] SIGKILL has been sent to vitsafehd 2020-01-01T05:55:55Z vitd: [etc/init.d/vitd] vitd is not running 2020-01-01T05:55:55Z vitd: [etc/init.d/vitd] vitsafehd is not running
Environment
VMware vSAN 6.x VMware vSAN 7.x VMware vSAN 8.x
Cause
When the ESXi host agents are restarted, the vSAN iSCSI vitd service, vitsafehd service, and watchdog agent will be restarted. As these are vSAN processes the ESXi host agent is unable to restart these services.
Resolution
Workaround: If ESXi host agents have been restarted and vSAN iSCSI is not functioning as intended, run the following command on the affected ESXi hosts: # /etc/init.d/vitd io_reset