vSAN iSCSI target service interrupted if ESXi host agents are restarted
book
Article ID: 326906
calendar_today
Updated On:
Products
VMware vSAN
Issue/Introduction
Symptoms:
vSAN iSCSI target service IO could be interrupted and the service cannot be started when restarting the ESXi host agents.
In the /var/run/log/vitd.log, you see similar to:
2020-06-16T04:50:25Z vitd: [etc/init.d/vitd] SIGKILL has been sent to vitsafehd 2020-06-16T05:42:38Z vitd: [etc/init.d/vitd] vitd is not running 2020-06-16T05:42:38Z vitd: [etc/init.d/vitd] vitsafehd is not running 2020-06-16T05:58:31Z vitd: [etc/init.d/vitd] vitd is not running 2020-06-16T05:58:31Z vitd: [etc/init.d/vitd] vitsafehd is not running
Environment
VMware vSAN 8.x
VMware vSAN 7.x VMware vSAN 6.x
Cause
When the ESXi host agents are restarted, it will shut down the vSAN iSCSI vitd/vitsafehd as well as the watchdog daemon. As these are vSAN processes the ESXi host agents won't restart these services as part of a management agents restart.
Resolution
Be mindful of the ESXi host agents that need to be restarted during troubleshooting and only restart the host services that are absolutely needed to resolve the issue at hand.
Workaround: If ESXi host agents have been restarted and vSAN iSCSI is not functioning as intended to work around this issue, run this command on the affected ESXi host(s): /etc/init.d/vitd io_reset