Unable to login to RVC on vCenter (Windows / Appliance) error "No connections available"
search cancel

Unable to login to RVC on vCenter (Windows / Appliance) error "No connections available"

book

Article ID: 326847

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction



Symptoms:

 

  • After upgrading the vCenter server appliance, you may not be able to connect to Ruby vCenter Console. It may fail with an error "Failed to connect to localhost: Public key fingerprint for host 'localhost' does not match /root/.rvc/known_hosts:1. No connections available."
     
  • On Windows Server, we may see the below warning when we try to login to Ruby vCenter Console.
    "No argument is specified, connecting to localhost as [email protected] Connecting to localhost...
    Failed to connect to localhost: Public key fingerprint for host 'localhost' does not match C:/Users/<username>/.rvc/known_hosts:0.

    Connecting to my...
    Failed to connect to my: getaddrinfo: No such host is known.
    No connections available."

 


Environment

VMware vSAN 6.5.x
VMware vSAN 6.7.x
VMware vSAN 6.x

Cause

This can be due to the "Public key fingerprint for vCenter (host) does not match."

Resolution

To resolve this issue:
 
On vCenter Server appliance
  1. Login to vCenter shell using root.
  2. Navigate to "/root/.rvc" and rename the file "known_hosts" to "known_hosts.bak"
  3. Try to login to the Ruby vCenter Console using username@domain@hostname and password.
    Ex: [email protected]@localhost
On Windows vCenter
  1. Navigate to the path "C:/Users/<username>/.rvc/known_hosts:0" and you will find known_hosts file.
  2. Rename the file known_hosts or move it to a different location.
  3. Try login to the Ruby vCenter Console.

Alternatively the current known_hosts file can be edited using a text editor to remove the line referencing to outdated fingerprint information - the updated fingerprint will be saved when prompted on next login.
 


Workaround:
If editing/removing the known_hosts file is not possible, alternative login names for localhost/loopback such as 127.0.0.1 or 127.1 can be used.

Additional Information

Error stack may look like this:

Try "--help" or "-h" to view more information about RVC usage.
No argument is specified, connecting to localhost as [email protected] Connecting to localhost...
Failed to connect to localhost: Public key fingerprint for host 'localhost' does not match C:/Users/<username>/.rvc/known_hosts:0.
Connecting to my...
Failed to connect to my: getaddrinfo: No such host is known.
No connections available.