Virtual machine lose network connectivity when running the services.sh restart command on the ESXi host when using Link Aggregation Control Protocol (LACP) LAG on the vSphere Distributed Switch
search cancel

Virtual machine lose network connectivity when running the services.sh restart command on the ESXi host when using Link Aggregation Control Protocol (LACP) LAG on the vSphere Distributed Switch

book

Article ID: 326840

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
When using Link Aggregation Control Protocol (LACP) Link Aggregation Group (LAG) in the VMware vSphere Distributed Switch (vDS), you experience these symptoms:
  • Virtual machines lose network connectivity after restarting the VMware ESXi host Management Agents using this command services.sh restart.
  • You are using Link Aggregation Control Protocol (LACP) Link Aggregation Groups (LAG) in the VMware vSphere Distributed Switch (vDS).


Environment

VMware ESXi 3.5.x Embedded
VMware ESXi 4.1.x Embedded
VMware ESXi 3.5.x Installable
VMware ESXi 4.0.x Installable
VMware ESXi 4.0.x Embedded
VMware vSphere ESXi 5.5
VMware vSphere ESXi 6.5
VMware ESXi 4.1.x Installable
VMware vSphere ESXi 6.0
VMware vSphere ESXi 5.0
VMware vSphere ESXi 5.1

Cause

This issue occurs due to the LACP module on the ESXi host restarting with all the other management services as this is part of the init.d scripts.

The virtual machines lose network connectivity at the time of the LACP module restart in both active and passive mode of LACP LAG on the vSphere Distributed Switch (vDS).

Resolution

This is a known issue affecting VMware ESXi 5.5.x and ESXi 6.0.x.

Currently, there is no resolution.

To confirm if LACP is in use run the following command:
esxcli network vswitch dvs vmware lacp status get

To work around the issue, restart the specific ESXi host Management Agent individually instead of using the services.sh restart command.

Note: You can individually restart a specific ESXi host Management Agent.

To individually restart a specific ESXi host Management Agent:
  1. Log in as root to the ESXi host using SSH.
  2. To restart a specific agent, run this command:

    /etc/init.d/Agent_Name restart

    For example:

    /etc/init.d/ntpd restart

    Note: Usage: <Agent> {start|stop|status|restart}


Additional Information

To be alerted when this document is updated, click the Subscribe to Article link in the Actions box.

当在 vSphere Distributed Switch 上使用链路聚合控制协议 (LACP) LAG 时,若在 ESXi 主机上运行命令 service.sh restart,虚拟机将丢失网络连接
vSphere Distributed Switch で Link Aggregation Control Protocol (LACP) LAG を使用している場合に ESXi ホストで service.sh restart コマンドを実行すると仮想マシンがネットワーク接続を失う

Impact/Risks:
VMware vSAN environment where LACP is configured may also be impacted when the ESXi Management Agents is restarted using the command services.sh restart.