Q: What does File Service - Share Health check do?
It checks if the file service share is in a good state.
Q: What does it mean when it is in an error state?
The 'Reason' column will provide details of the error message which can be referred to from the following table:
| Check Item | Error Message Type |
|---|
| Share Health | No backing vSAN object found for this file share, or the VDFS daemon for this file share is not working |
| Used capacity of this share exceeds the soft quota |
| Backend vSAN objects are not compliant with non-availability related policies |
| Storage policy contents of this share has been reconfigured and does not match anymore |
Q: How does one troubleshoot and fix the error state?No backing vSAN object found for this file share, or
the VDFS daemon for this file share is not working1. Check VDFS daemon status on the Host on which the File Share is located by:
2. Check the Health Status of the related vSAN Object of the File Share
By reviewing
File Share Objects Health or by
reviewing the general vSAN Object Health in vSAN Health ServiceUsed capacity of this share exceeds the soft quotaThis alarm refers to File Share usage.
The alarm can be resolved by either moving/removing some files from the File Share
or reconfiguring the File Share with a larger soft quota (via
Edit a File Share )
Backend vSAN objects are not compliant with non-availability related policiesCheck the storage policy is compliant for the backing object.
Storage policy contents of this share has been reconfigured and does not match anymore
Reconfigure the storage policy of the file share.