Datastore does not match current VM policy
search cancel

Datastore does not match current VM policy

book

Article ID: 326824

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • When attempting to clone the vSAN default storage policy, the vSAN datastore appears as incompatible with the reason: "Datastore does not match current VM policy."

     

  • vSAN Cluster > Monitor > vSAN > Capacity, the storage policy displayed under "With the policy" is not vSAN default storage policy.
  • In some cases,Creating a VM with the vSAN Storage policy may fail with the above error.

  • vSAN datastore may be listed in "incompatible" datastore during creation.

Environment

VMware vSAN 7.x
VMware vSAN 8.x

Cause

On occasion, when a new vSAN cluster is deployed, it can fail to get added to the vCenter Storage Policy Service correctly, leaving the entry in an unhealthy state.

 

Resolution

To resolve this issue,

  1. Check Service Status: 
    Log into the vCenter Server Appliance (VCSA) via SSH and verify if the vmware-vsan-health service is running using service-control --status vmware-vsan-health.
  2. Start/Restart Services: 
    If the service is stopped, start it with service-control --start vmware-vsan-health. If it is running but the error persists, restart the Storage Policy Service: service-control --restart vmware-sps.
  3. . If the problem is still in place after restarting the service above, then re-synchronize the storage providers from vCenter by doing the following:
    • Select the vCenter in the left pane
    • Select the Manage/Configure tab
    • Select Storage providers
    • Click on  Synchronize Storage Providers, the icon that looks like a stack of disks with the circular red arrows.
  4. VCSA Reboot: If services fail to initialize due to API timeouts (often seen with high system uptime), perform a graceful reboot of the VCSA. 



Additional Information

VASA provider registration Troubleshooting
VASA Provider Registration Troubleshooting