VMware Cloud on AWS vSAN Advisory
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VMware Cloud on AWS vSAN Advisory

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Article ID: 326791

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Updated On:

Products

VMware vSAN VMware Cloud on AWS

Issue/Introduction

This article provides information regarding a potential data inconsistency when very specific conditions are met for VMDK's residing on VMware vSAN 6.6 and later.

Note: This behavior is exhibited only under very specific conditions.

Symptoms:
Applications such as databases report in-guest data inconsistency on a VMDK that has been extended while residing on VMware vSAN 6.6 and later.

Environment

VMware vSAN 6.x

Cause

This issue occurs because in VMware vSAN 6.6 and later, under specific conditions, virtual machine disks residing on vSAN that have been extended may encounter data inconsistencies. This is a rare occurrence, requiring specific conditions to be met.

Resolution

This is a known issue affecting VMware vSAN 6.6 and later versions.

This issue has been fixed in version SDDC 5 patch 2

For VMware Cloud on AWS customers, VMware Engineering has already applied the configuration changes noted in the "Workaround" section of https://kb.vmware.com/s/article/58715.

Workaround:
VMware Cloud on AWS Engineering has already implemented the workaround to avoid future occurrence of this issue as detailed in https://kb.vmware.com/s/article/58715.

Note: If your application reports of data inconsistency errors, contact VMware Support and note this Knowledge Base article ID (58715) in the problem description. To contact VMware support, see Filing a Support Request in Customer Connect (2006985) or How to Submit a Support Request or the native chat client within VMware Cloud on AWS.

Additional Information

Impact/Risks:
Applications such as databases may report in-guest data inconsistency errors on VMDK's residing on VMware vSAN under specific conditions.