VMware ESXi 6.5, Patch Release ESXi650-201810001 - Updates esx-base, vsan and vsanhealth VIBs
search cancel

VMware ESXi 6.5, Patch Release ESXi650-201810001 - Updates esx-base, vsan and vsanhealth VIBs

book

Article ID: 326745

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:

Release date: November 29, 2018

Patch CategoryBugfix
Patch SeverityCritical
Host Reboot RequiredYes
Virtual Machine Migration or Shutdown RequiredYes
Affected HardwareN/A
Affected SoftwareN/A
VIBs Included
  • VMware_bootbank_esx-base_6.5.0-2.71.10868328
  • VMware_bootbank_vsan_6.5.0-2.71.10652415
  • VMware_bootbank_vsanhealth_6.5.0-2.71.10652417
  • VMware_bootbank_esx-tboot_6.5.0-2.71.10868328
PRs Fixed 2227187
Related CVE numbersN/A


Environment

VMware vSphere ESXi 6.5

Cause

Specific conditions in VMware vSAN 6.6 and later might lead to data inconsistencies in applications such as databases. The sequence of the following operations might cause the issue:

  1. vSAN initiates resynchronization to maintain data availability.
  2. You expand a virtual machine disk (VMDK).
  3. vSAN initiates another resync after the VMDK expansion.

The fix in this release prevents further data inconsistencies but does not recover data.

Resolution

Currently, there is no resolution.

Workaround:
To work around this issue, disable the in-place expansion.

Note: Below are applicable only when vSAN 6.5 Express Patch 9 is not installed.

To disable the in-place expansion:
  1. Log in to the ESXi host through SSH as root.
  2. Set the VSAN.ClomEnableInplaceExpansion advanced configuration option to 0 on all hosts.

    Note: Reboot is not required. The VSAN.ClomEnableInplaceExpansion setting does not affect host reboots or running workloads. After all hosts are upgraded, set VSAN.ClomEnableInplaceExpansion back to 1.