vSAN HCL DB Health Check Shows Red on Fresh Deployment Without Internet Access
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vSAN HCL DB Health Check Shows Red on Fresh Deployment Without Internet Access

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Article ID: 326619

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Updated On:

Products

VMware vSAN

Issue/Introduction

This article explains the vSAN HCL Health – vSAN HCL DB up-to-date check in the vSAN Health Service and provides details on why it will report an error.

Adherence to the Broadcom Compatibility Guide/Hardware Compatibility Guide (HCL) is critically important to the stability of vSAN environments. Experience has shown that failing to observe the VCG often leads to production outages over time. It is, therefore, very important to monitor the health checks in the HCL checker category. For more information, see the Broadcom Compatibility Guide.


Symptoms : 

  • vSAN skyline health reports error: vSAN HCL DB up-to-date.

Environment

VMware vSAN 6.#
VMware vSAN 7.#
VMware vSAN 8.#

Cause

This check uses thresholds of 90 or 180 days of age to show a warning or error, respectively. Those thresholds are on the high side, and VMware recommends keeping the database updated as often as operationally possible.

Note: As of version 6.7 U3 this warning will also trigger if one or more hosts are running a build of ESXi that is not on the HCL such as a pulled build or custom hot patch.

Resolution

To resolve this issue, use one of the options:

  • To allow auto-update from the Internet:
    1. Enable Internet access for the vCenter.
    2. Go to vCenter > Configure > vSAN > Internet Connectivity > Edit and enable Internet access.
  1. Then go to Cluster > Monitor > vSAN > Skyline Health > Hardware Compatibility > vSAN HCL DB up-to-date.
  2. Click GET LATEST VERSION ONLINE.
  3. Click RETEST. 
  • To manually update the HCL DB:
    1. On a workstation with Internet connectivity, browse to https://partnerweb.vmware.com/service/vsan/all.json (Right-click, Save as)
    2. Save the file as all.json. If you cannot save the file, you must copy the entire content and create a new file with the extension "*.json."
    3. Go to Cluster > Monitor > vSAN > Skyline Health > Hardware Compatibility > vSAN HCL DB up-to-date.
    4. Click UPDATE FROM FILE
    5. Select a valid HCL file with the latest or newer timestamp.
    6. Click RETEST.

Further information about updating from the file can be found in the following KB, Updating the vSAN HCL database manually.

Additional Information

Q: What does the vSAN HCL Health – vSAN HCL DB up-to-date check do?

This health check verifies the VMware Compatibility Guide database used for the HCL checks is up-to-date. These VCG checks are not done against the HCL on the VMware website, but rather against a copy stored on the vCenter Server.

The initial release of the health feature ships with a copy of the HCL database, which was current when released. This copy of the database will become outdated over time. This is especially true as new certifications with partners get added to the VCG.

Note: Hardware vendors regularly update their drivers and send them for VMware certification. Older drivers may even get removed from the VCG to reflect issues found. Therefore, it is critically important to keep the local copy up-to-date.


Updating the VSAN HCL & Release Catalog DB using VSAN API
vSAN Health Service - Hardware compatibility - vSAN HCL DB Auto Update (2146132)
vSAN Health Service - vSAN HCL Health – vSAN HCL DB update manually