Cannot add 1 disks to SSD. Currently mapped 7 disks, maximum 7 disks. While adding disk to diskgroup.
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Cannot add 1 disks to SSD. Currently mapped 7 disks, maximum 7 disks. While adding disk to diskgroup.

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Article ID: 326564

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Updated On: 12-01-2024

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • Adding a replaced disk back to the disk group fails with the error similar to: 
A general system error occurred: Cannot add 1 disks to SSD. Currently mapped 7 disks, maximum 7 disks.
  • In the /var/log/vmkernel.log file, you see the entries similar to:
ScsiDevice: 4008: Can't unregister device naa.5000cca0710d55a1 because it is in use. OpenCount:1 InternalOpenCount:0 RefCount:2 FilterCount:0
WARNING: NMP: nmpUnclaimPath:1516: NMP device "naa.5000cca0710d55a1" quiesce state change failed: Busy
StorageApdHandlerEv: 110: Device or filesystem with identifier [naa.5000cca0710d55a1] has entered the All Paths Down state.
WARNING: NMP: nmp_IssueCommandToDevice:4553: I/O could not be issued to device "naa.5000cca0710d55a1" due to Not found
WARNING: NMP: nmp_DeviceStartLoop:725: NMP Device "naa.5000cca0710d55a1" is blocked. Not starting I/O from device.
ALERT: NMP: vmk_NmpVerifyPathUID:1190: UID of a device (path vmhba6:C1:T4:L0) has changed from naa.5000cca0710d55a1 to naa.5000cca07f17699. Critical error if data LUN.
WARNING: NMP: nmpDeviceAttemptFailover:678: Retry world failover device "naa.5000cca0710d55a1" - failed to issue command due to Not found (APD), try again...
ScsiDeviceIO: 2595: Cmd(0x43a5c11e2a40) 0x9e, CmdSN 0x4bbe2 from world 0 to dev "naa.5000cca0710d55a1" failed H:0x8 D:0x0 P:0x0
ScsiDeviceIO: 2651: Cmd(0x43a5c11e2a40) 0x25, CmdSN 0x4bbe3 from world 0 to dev "naa.5000cca0710d55a1" failed H:0x1 D:0x0 P:0x0 Possible sense data: 0x5 0x20 0x0.
WARNING: ScsiDeviceIO: 9280: READ CAPACITY on device "naa.5000cca0710d55a1" from Plugin "NMP" failed. I/O error
ScsiDevice: 4008: Can't unregister device naa.5000cca0710d55a1 because it is in use. OpenCount:2 InternalOpenCount:1 RefCount:5 FilterCount:0
WARNING: ScsiScan: 1291: The physical media represented by path vmhba6:C1:T4:L0 has changed. Found path UID naa.5000cca07f17699. This is a critical error.
PLOG: PLOG_InitDevice:262: Initialized device naa.5000cca07f17699:1 0x430c6aeef010 quiesceTask 0x439e15132e00 on SSD 52a5ea9f-02f2-5fbc-4bce-c61bdb24935cdeviceUUID 00000000-0000-0000-0000-000000000000
PLOG: PLOGProbeDevice:5466: Probed partition naa.5000cca07f17699:1 of disk naa.5000cca07f17699 hot added
PLOG: PLOG_InitDevice:262: Initialized device naa.5000cca07f17699:2 0x430c6ae6bca0 quiesceTask 0x439e1513c700 on SSD 52a5ea9f-02f2-5fbc-4bce-c61bdb24935cdeviceUUID 00000000-0000-0000-0000-000000000000
PLOG: PLOGProbeDevice:5466: Probed partition naa.5000cca07f17699:2 of disk naa.5000cca07f17699 hot added
PLOG: PLOG_OpenDevHandles:1228: Registered APD callback for naa.5000cca07f17699:2 52ac0ee6-945a-e71d-2566-adcdf328545d
WARNING: PLOG: PLOGVsi_DeviceUnmapInfoGet:1128: Get unmap granularity on device naa.5000cca07f17699 failed with status Not supported
LSOMCommon: LSOMDiskReadGetWCEnableSAS:749: WC is enabled:NO on disk naa.5000cca07f17699
PLOG: PLOGProbeDevice:5214: Probed plog device <naa.5000cca07f17699:2> 0x430c6ae6bca0 exists.. continue with old entry
PLOG: PLOGMapDataPartition:2201: Mapping SSD cache data partition for naa.5000cca07f17699 not found
PLOG: PLOGProbeDevice:5214: Probed plog device <naa.5000cca07f17699:1> 0x430c6aeef010 exists.. continue with old entry
Vol3: 2687: Could not open device 'naa.5000cca07f17699:1' for probing: No underlying device for major,minor
Vol3: 1078: Could not open device 'naa.5000cca07f17699:1' for volume open: No underlying device for major,minor
FSS: 5338: No FS driver claimed device 'naa.5000cca07f17699:1': No filesystem on the device

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.



Environment

VMware vSAN 7.0

VMware vSAN 8.0

Cause

This issue occurs because the original disk was either faulty or wasn't removed properly.

Resolution

To fix the issue on vSAN cluster.

NOTICE: Make sure to have a healthy backup of the data before performing the below steps.

  • Identify the host with problematic disk.
  • Put the host into maintenance mode with Ensure Accessibility.

If the cluster is not configured with deduplication.

  1. Take a SSH session to the ESXi host.
  2. Try to unmount the disk by running localcli vsan storage diskgroup unmount -d <disk id>
  3. If unmount fails then try to remove the disk by running esxcli vsan storage remove -u <Disk UUID>
  4. If unmount and remove fails then try rebooting the host.

If the cluster has deduplication configured.

  1. Follow KB How to manually remove and recreate a vSAN disk group using esxcli (2150567)
  2. If option 1 fails reboot the host.

 

Additional Information